Mac, iPhone, iPad, iCloud, Apple watch user? Update now to plug a security vulnerability

Issued on 26 January 2021 Apple have updated software supporting their products and services that closes a recently exposed and exploited vulnerability. Which is? The ability for a malicious application that can elevate privileges to gain higher level access and control critical files/functions. The exploit isn’t specific and affects different devices in different ways.

If you use a:

  • Mac with macOS Catalina 10.15.4 and later
  • PC using iCloud for Windows 12.0 Windows 10 and later
  • iPhone using iOS 14.4 and iPadOS 14.4 iPhone 6s and later,
  • iPad Air 2 and later, iPad mini 4 and later, and iPod touch (7th generation)
  • Apple TV using tvOS 14.4 Apple TV 4K and Apple TV HD
  • Apple Watch Series 3 using watchOS 7.3 and later

Check and update your software when possible.

For more information and updates check Apple Support https://support.apple.com/en-nz/HT201222

While ensuring software is kept as up-to-date as possible this is one instance where we urge you to update now, to save time later.

Got a question? Want to know more?

Please enter your name.
Please enter a message.
Please check the captcha to verify you are not a robot.